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lundi 21 janvier 2008

Ce tutorial vous guide dans I'utilisation de Netbeans (version 6.0) pour créer vos propres bibliotheques de
balises personnalisées (custom tags).

Créeer un projet d’application Web sous Netbeans

1) Créez un nouveau projet (menu File>New Project)

2) Sélectionnez la catégorie Web et le type de projet Web Application

3) Choisissez un nom de projet (TPCustomTags par exemple), un répertoire de stockage (Project
Location), un serveur d’application (Apache Tomcat), une version de JEE (Java EE 5) et validez la
création (bouton Finish).

W Hew Project X
Steps Choose Project
W TestCustomTag1 - NetBeans IDE 6.0
Gl Edt View Navigate Source Refactor B 1. ChooseProject P i e
5 ] - . .. ) Jawa 1
0 Mew Project... Chri+Maj+i 3 web {2 Web Apphcation with Existing Sources
P New File... Ctrl+ | & Enberprise A Web Apphcateon with Existing Ant Sorpt
C ) MetBaans Modubes
(&5 Open Project... Chri+Maj+0 03 Samples
Open Recent Project b
Clase "TesbCustomTagl”
Description:
Creates an emply Web application in a standard [DE project. & standard
project uses &0 IDE-genersted build script to buld, ron, snd debaug your
project.

T New Web Application

Steps Narre and Location = E
1. Chooss Project Project Mame: TPCustomTags E
2, Mame and Location

Y. Pk Project Location: | PA\ENSEIGNEMENT\Serveurs MvaltdsisujetsitdCustomTe| [ Browse..,

Project Folder: | 3 MENT|ServeursJanalbdstsussts|bdCustonT sgs| TPCus

#udkd ko Enkarpeise Apphoation:

Servern: jApache Tomoal 6.0. 14

Attention | Sélectionnez bien le
serveur Apache Tomcat

et non pas le serveur GlassTish,

Le premier ezt un simple canteneur
web, alors que le second est un
serveur d'application JEED
complet et est donc beaucoup plus
[L<pock J[ met> J[ Fneh |[ concel J[ nee | gourmand en ressources

Yovs EE Wergion: | lavaEES ~
Conkext Path: ITPCrsboemT g

[=] 5ot &5 Main Project
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Un projet d’application web est crée, sa hiérarchie est la suivante. Il contient une seule page index. jsp :

=4} TPCustomTags
5 3 Web Pages
-0 META-INF
=10 WEB-INF Les pages webs (html. j=p) et images

F index.jsp
=8 Configurstion Fles

[€] MaNIFEST.MP

|:_';j cortecdt.xml
[GH weeb.xml
g Server Resources
=i Source Padkages .
& -cdefa-.tpa-:kauw} Les claszes java
+-10) Test Packages
¥ @ Lbraries
¥ Test Libraries

Les fichiers de configuration

4) lancez I’exécution de ce projet (c'est-a-dire sa compilation et son déploiement dans le serveur Tomcat
intégré a Netbeans) simplement en cliquant sur le bouton de la barre d’outil de Netbeans.

ﬁ Si vous travaillez sur les terminaux SunRay et que vous vous connectez sur les serveurs

imablade pour lancer Netbeans, il faut configurer le serveur Tomcat de Netbeans pour

fixer des numéros de ports différents selon les utilisateurs. Donc avant de poursuivre
référez vous a I’annexe Configuration de Tomcat/Netbeans pour les serveurs imablade.

W MetBeans IDE 6.0

File Edit Wiew Mavigate Source Refactor  Build Run Profileal'ersioning  Tools  Window  Help

FEES XBEDE TR G-
[EPrujects 10 x]EFiles - Services : Profiler %

Le serveur Tomcat est automatiquement lancé, et une 1’application lancée dans votre navigateur.
(Remarque : vous pouvez choisir le navigateur ouvert (Mozilla, IE, ...) a l'aide du menu
Tools>Options).

¥ Options

@ r E {_} ; -

= 7\ |
o v @& @H= ®
General Editor Java Code  Fonts & Colors Keymap Miscellaneous

Web Browser: <Default System Browser = L' Edit...

Internet Explorer

Proxy Settings: FI{EF.D.X.. .
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Votre navigateur affiche la page index. jsp (qui ne propose pas grand-chose ... pour le moment).

) JSP Page - Mozilla Firefox M=
Fichier  Edition  Affichage  Historigue  Marque-pages  Outils 7

- - @] ﬁ |@ http: f flocalhost: G064 TPCuskom Tags) |‘| [3"] 9,
Hello World!
Terrminé (]

Creer un premier tag personnalise : HelloTag

Vous allez maintenant créer un premier tag personnalisé qui affichera tout simplement le texte Bonjour
Monde Cruel !!! en gras. Tout d’abord il vous faut définir la librairie de tags a laquelle sera associé votre
nouveau tag. Pour cela procéder comme suit :

1) Créez un nouveau fichier de type Tag Library Descriptor (TLD). Soit par le menu File>New
File, le bouton New File de la barre d’outils ou un clic droit sur le projet dans le navigateur. Dans la
catégorie Web sélectionnez le type de fichier Tag Library Descriptor.

® New File X
Steps Choose File Type
1. Choose File Type Project: |Q::l§ TPCustomTags b |
2
Categoaries: File Types:
|3 web ~| |[€ wHm ~
d[3) Javaserver Faces Ty Cascading Style Sheet

() Struts @ JavaScript File
e &8 I50M File

) @ Tag Handler
la Sl o %% Tag Library Descriptor
LT Persistene bt @ Taq File
< | (& W
o=l L Il L
Description:

2

Creates a Taq Library Descriptar {TLD) file, which can be used with
JavaServer Pages (J5P) files. & tag library descripkor is an ®ML
document that contains information about a library as a whole and

£ |

Un assistant (wizard) de création de fichier TLD s’affiche. Renseignez le nom de la bibliotheque de tags
(par exemple avec maTagLib) et validez (bouton Finish les autres valeurs proposées par défaut par
NetBeans sont suffisantes).
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W Mew Tag Library Descriptor @

Steps Mame and Location
1. Choose File Type TLD Name: | oEeE
2. Mame and Location
Prioject: TPCustomTags
Location: ‘Web Pages w
Folder: WEB-INF ftids/ Browse...
= {0 TPCustomTags : .
563 Web Pages Crested File: AtdCustomTags|TPCustomTags|web)WEB-INFitidsimaTagLib.t
* -_']INF
=) WEB-INF URL: | MWEB-INFftidsfmaTaglib
¢ € maTsabtd Rl mak gt
) index.jsp
=&} Configuration Files
(@] MANIFEST.MF
B contest.uml < Back N | Fnish || cancel |
_‘E web,xml
L@ Server Resources
=g Source Packages
[F| =default package>

Un fichier maTagLib.t1d est créé dans le répertoire Web—INF/t1ds de votre application et est ouvert
dans I’éditeur.

2) 11 vous faut maintenant créer votre gestionnaire de tag (tag handler). Créez un nouveau fichier de type
Tag Handler... (comme précédemment vous passerez par le menu File>New File, le bouton New
File de la barre d’outils ou un clic droit sur le projet dans le navigateur).

L’assistant de création de gestionnaire de tag s’affiche. Dans le premier panneau vous préciserez le nom
de votre gestionnaire de tags (par exemple HelloTag) et son package (par exemple mestags).

W Mew Tag Handler [gl
Steps Mame and Location
1. Choose Fils Type Class Marne: | |

2. MName and Location
3. TLD Infarmation

Project: |TPCustDmTags |
Location: |Snurce Packages b |
Package: |mestags - |

Zreaked File: |ursJ.D.\p'.C\'l,tds'l,sujets'l,tdCustomTags'l,TF'CustomTags\,src\,java\,mestags'l,Hel|

Tag Support Class to Extend:
(%) SimpleTagSuppork {JZEE 1.4}
() BodyTagSupport

Description:
|Creates a tag handler that extends javax servlet.jsp. tagext. SimpleTagSupport.,

< Back ] I Mext = Finish Help
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Passez a I’étape suivante (bouton Next) et renseigner les différents champs pour le descripteur de votre
tag personnalisé dans le fichier .t1d de votre bibliotheque :
¢ Le nom du tag (par exemple hellotag),
e Le type de corps (body), ici empty,
e Le fichier TLD, vous sélectionnerez le fichier maTagLib.t1ld créé précédemment (bouton
Browse).

Un package mestags et un fichier HelloTag. java sont crée dans votre projet et un éditeur est ouvert
sur le fichier HelloTag. java.

® New File (X]

Steps TLD Information

1.  Chooss File Type
2. MName and Location
3. TLD Information

Add Corresponding Tag to the Tag Library Descriptor

Spexify the tag lbrary descripbor that the tag should be added to:

TLD File: Browss...
Tag Name: hellotag W Browse Files EJ
Tag Handler Class: |mestags.HelloT.
a9 g5 ag Polders:
’ =10 Web Pages
= ) TPCustomTags Hochi cane et Clemecis. Baate i -0 META-INF
=03 Web Pages . =i 'WEB-INF
®-1C META-INF .u.tt; : =00 tids
=10 WEE-INF Hame Type Required [ WmaTaglib, td
-0 tids & web.oanl
&% maTaglib.tid ] index.jsp
[B web.aml
LIEI ek P Thee Tag Library Descripbor (TLD file) need bo be spey
B Fmﬁ:;.ratm Files &) one must be created first, The Tag].uhral\; Descript
[@] mantFesT.MF purpose,
[ context.xml | selectFle || Cancel
L:.'g, web.xml
0@ Server Resources < Back " Cancel™ |
=) Source Packages
=-EH mestags

3) Modifiez comme suit le code de la méthode doTag de votre classe HelloTag. java afin que celle-ci
écrive Bonjour Monde Cruel !!! sur la sortie de votre page JSP.

public void doTag() throws JspException !

Japllriter out=getJdsplontext().getlut() !

try |
out.println("<strong=Bonjour Monde Cruel !'!!</strong="");

} catch (Jjava.io.I0Exception ex) |
throw new JspExceptioni(ex.getMessage(]):
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Sauvegardez le fichier !

4) Modifiez la page index. jsp. Ajoutez la directive taglib pour déclarer la bibliotheque de tag et
I’invocation de votre nouveau tag hellotag.

I 151 4 F= T | = =l = sl e Il =1 5 =1 T W Bl S S
Swataglib uri="/WEE-INF/tlds/maTaglib. tld” prefix="mataglib™ %> \

<'DOCTYPE HTHL POBLIC - 050 /DT HIML 4,01 Transitionals /RN
http: /Asvmmr, w3 org A TRE/htmld s loozse. ded™ -

Déclaration de la bibliothéque de

&

<html=
<head
<meta http-equiv="Content-Type"™ content="text/html; charset=UTF-3">
£titlexd3F Page</titles
<fhead=
<hody>-
aheshello WMorldl- b
mataglib:hellotags> | ® Invocation du tag
< hodys
</html>

5) Sauvegardez le fichier index. jsp et relancez votre application (bouton Run de la barre d’outils).

W NetBeans IDE 6.0
File Edit View MNavigste Source Refactor Build Run Profile Versioning Tools Window Help

Fichier Edition  Affichage  Historigue  Margue-pages  Outils  ?

} o @] Jur} |@ hitp: /flacalhost: G084 TPCustomT ags| |v| l}] %
[#] 35p Page | [#] 5P Page Gl -
Hello World!

Bonjour Monde Cruel !!!

Terming (]

Ajout d’un attribut au tag HelloTag.

Dans ce qui suit vous allez modifier votre gestionnaire de tag de maniere a ce que I’utilisateur puisse
paramétrer le message afficher a I’aide d’un nom.
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1) Modifiez le fichier maTagLib.t1d pour rajouter la description d’un attribut pour le tag HelloTag.

<tams
<nameXxhellotag fnane-
<tag-classrunestags.HelloTag /tag-classs
<hody-content-empty /hody-contents-
<attributer | | nomdu tag
<NAamnernanes Mnanes .—'—'_'_'_'_'_'_._'_._
1 & =
<rtexprvalue-trues /rtexprvalue- . I u1"|'r'|bu1' FELH' etre
L4 1
<typexjava. lang. String(,ftm:ue}-».\ le résultat d'un '|'I‘J.g
</attributes N d'expression
< S tags
</taglib> R type du tag

Sauvegardez le fichier maTagLib. jsp

2) Modifiez le gestionnaire de Tag (HelloTag. java) pour y ajouter le support de I’attribut name.

package mestags:

import jawvad.serwlet.jsp. tagext. !
import jawvax.servlet.jsp.Jsplriter;
import jawvax.serwvlet.jsp.JdspException:

public class HelloTayg extends JimpleTagiupport |

«— I'attribut
private 3tring name = "Monde Cruel™:

public woid setHame |(String name) | e lamdthode "setter"
this.naue = naue; permettant a une page JSP
; de fixer sa valeur

public void doTag() throws JspException |

JapWriter out = getdspContext(].getiut(]; modification de la méthode M
pour prendre en compte |'attribut

try {

out.println("<strong="§+ name +§" !l Sstrong=")

} catch [(Java.io.I0Exception ex) !
throw new JspException(ex.getMessage()):

Sauvegardez le fichier Hel1loTag. jsp

3) Modifiez la page index. jsp pour y ajouter un appel a votre tag avec un parametre.
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package mestags:

import jawvax.serwvlet.jsp. tagext.®;
lmport Jjavax.serwlet,]sp.JspWriter;
import javax.serwlet,]sp.JspException:

public claszs HelloTayg extends SimpleTagiupport

«— —— I'attribut

private String name = "Monde Cruel™:
. B B L 1] [1]
public woid setWame (3tring name) ! e lamethode ["setter
this.name = name; permettant|a une page JSP
; de fixer savaleur
public void doTag() throws JspException |
Tapliriter out = getJspContext{).getlut{); modification de la méthode doTag

.,/ pour prendrg en compte |'attribut

Ly |

rr

+ name H

rr

mt.println("<strong=Eonjour

} catch [(java.io.I0Exception ex]

{

"l fatrong-") ;

throw new JspException(ex.getMezsage()):

4) Sauvegardez le fichier index.jsp etrelancez I’application (bouton Run de la barre d’outils).

W NetBeans IDE 6.0
File Edit View MNavigate Refactor Build Run Profile Versioning Tools ‘Window Help

PEES X2E9¢ TH OB G-

Cikils

Source

=

Fichier  Edition  Affichage

Hello World!

Histarique  Margque-pages T

ﬁ i@ htkps i flocalhost: 80584 TPCustomTags/ |"| [3“] %

Bonjour Monde Cruel !!!
Bonjour TOTO !

Terminé
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Exercices

Les exercices suivants reprennent les exemples présentés a la fin du cours (voir les transparents en ligne
http://www.inrialpes.fr/helix/people/genoud/ENSJAV A/cours/supportsPDF/JSP_2pp.pdf).

1) Rajoutez a votre bibliotheque de tags un nouveau tag qui admet un corps. Ce tag admet un parametre
(obligatoire) name de type chaine de caracteres. Le résultat produit est I’encadrement du texte situé a
I’intérieur du corps du tag par HELLO name et BYE name comme le montre la figure ci-dessous.

) Exemple d'une Page JSP avec un ... |Z||i Ead

<mesTags :HelloRvecBodyTay nane="TITI >

Fichier  Edition  Affichage  Historiqgue  [Margue-pages

Ceci est un texte pour
pour montrer comment cela marche

le corps (body) du TAGER-

- - @ W @ [FErwi[p] §

< fmesTags :HelloAvecBodyTaug-

HELLO TITI

Cect est un texte pour e corps (body) du TAG
pour montrer comment cela marche

BYE TITI

Terming (]

2) Apres avoir tester votre tag précédent modifiez le, de maniere a ce que le texte affiché soit transformé

en majuscule.

~mesTags :Hell ohvecBodyTay nane="TITI"=

Ceci est un texte pour le corps (body)] du TAGERE-

PoUr montrer comment cela marche

< fmesTags :HelloAvecBodyTag-

chier Edition  Affichage  Historique  Marque-pages  OQukils 7
- - l\é‘:’] ﬁ |@ http:/flocalhost: 3034 | '| [}‘] %
4
HELLO TITI

CECIEST UM TEXTE POUE LE COERS (BODY) DU TAG
POUER MONTEEE. COMMEINT CELA MARCHE

BYE TITI

Terming (]

Indication : on utilisera un objet StringWriter comme parametre dans le message invoke envoyé au
corps du tag pour récupérer la chaine correspondant au corps, chaine qui sera ensuite transformée en
majuscules (méthode toUpperCase () de la classe String) avant d’étre envoyé sur la sortie de la page

Isp.
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3) Ecrire deux tags switchtag et casetag qui lorsqu’ils sont imbriqués reproduisent le fonctionnement
d’une instruction switch case des langages de programmation.

£% for {int 1 = 0; i < 5; i+H+) { 5

\ .
——® Integer walTest = (int] (Math.zrezndom(] * 3):%> lon la valeur de |'attribut
<H1> / test, le texte contenu dans le

<mesTags:switchtay test="<%=valTest.toltring()%>"> co ps dLI fﬂg casetag

<mesTags:casetay value="0">cas 0</mesTays:casetay- gqg r‘espondanf est affiche
-mesTaygs: casetayg value="1">caz l</mesTags:casetag-
-mesTaygs: casetay value="2">caz Z</mesTags:casetag-

<fmesTays : switchtag- I
2 Exemple d'une Page J... E|E]Fz|

< Hl>=
_-. - L el ce
el Fichier  Edition BIifssEREN Historique  Mar
P @O M Ew
Pour tester le
”

|___fonctionnement des tags, le

tag swit.chtag est invoqué 5 .
fois avec une valeur tirée au cas 0
hasard entre O et 2

cas 2

cas 0

cac 1 o

Terminé (]
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Annexe
Configuration de Tomcat/Netbeans pour les serveurs imablade.

Lorsque vous utilisez le serveur Tomcat de Netbeans, celui-ci utilise par défaut les ports 8084 et 8025. Si
plusieurs Netbeans tournent sur une méme machine (ce qui est le cas lorsque vous travaillez sur les
serveurs d’application de I’'UFR IMA), il faut attribuer des numéros de port différents pour chacun des
serveurs Tomcat. Pour cela procéder comme suit :

1) Sélectionnez l'onglet Services (si il n’est pas présent, vous pouvez l’afficher par le menu
Window>Services).

2) Développez le nceud Servers (en cliquant dessus) et selectionnez le nceud Apache Tomcat.

3) Ouvrez le fenétre de configuration des propriétés du serveur (clic droit sur le noeud Tomcat et
sélection de I'item Properties dans le menu contextuel). Dans celle-ci fixez les numéros de
ports (Server Port ET Shutdown Port) en choisissant des numéros qui ne sont pas utilisés.

MetBeans IDE 6.0

Eile Edit View Mavigae Source Refgctor Build Bun Profile Versjoning Tools Window Heip

PEHES XEDETE DB G-
Stnnrt:t®

Frojects Filex il % Start Page x| B intexjip x d| k= O] Paleite
o [l Daabases — . f P & HTML
i ] g B & =
o= ﬂ ‘Web Services I%’ u I& 5 Ea U/ Q"’ = -I -I LN | Takle
o= Q Enterprize Beans (2.2} o n ‘—’
o B Servers Document : dndex [ Image
g Created on @ 22 janv. 2008, 10:45:43 & HTML Form
¥, B [owcx Rl Author : genoudph
- {‘_.B,C!a::Flsﬂ V2 L ; &= 5P
¥ RF
Servers
SEMVRFE:
] Java EE Servers Server Name: apache Tomes 6.0.14 H
%, Apache Tomeat 6.0.14 Server Type: Tomewm 6.0
& ClazFish V2
Connection | Startup | Platform | Deployment I Clagses [ Cources ] Jeeadoc
Cusding Home:  fusrflocalfjavafapache-tomcat-6.0.14
Index jsp = Navigator
& @ himi Canaling fase SufHOME/ g/ genoudphf netbeans /6.0 /apache-tomoat-6.0.14_baze
&= @ head
¥ @ body Credertials of an existing user in the “manager robe
@ h
Username ide
Farpaord SEEEEREN S
serer Port 8084
Shutgawn Part s0z5E
[+] Emable HTTP Monitor
Mote: Changes will takoe affect T next 1ime you Star the Server
Add Server L i
Cutpun leeet i ! )

TTBrary-1nciusicon-1n-man rest:
compile:
compile-japa;

Java DB Database Process = ﬁlus“
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Au cas ou les numéros que vous auriez choisis serait déja utilisés un message d’erreur est affiché sur la
console au lancement de Tomcat.

Cutput

5 x| HTTR Moaonitor

b [ Java DB Database Process x| GlassFish V2 x| Apache Tomcat 6.0.14 Log x| Apache Tomcat 6.0.14 x| WebApplicationZ (

compile:

at
at
at
at
at
at
at
at

compile-jsps:
Starting of Tomcat failed, the server port 3034 is already in use.
Deplaoyment error:

Starting of Tomcat Tailed, the server port 3034 is already in use.
See the server
org.
arg.
org.
SUR.
sUh.

Mbrary-1nclusion-1n-manl test:

Tog for details.

netheans.modules. jZee.deployment.devmodules. api.Deployment.deploy(beployment. java:1635])
netheans.modules, jZee.ant. Deploy.executeDeploy. java: 104]

apache. tools.ant.UnknownElement. execute (UnknownElement. java: 25387
reflect.GenerateddethodAccessoras,. invoke(Unknown Source’
reflect.belegatingMethoddccessorIngl.invoke(DelegatingdethodAccessarIngl . java: 257

java. lang. reflect. Method. invoke(Method. java: 597

org.
org.

apache,tools,ant.dispatch.Mspatchltils.execute(Dispatchltils. Java: 1057
apache. tools.ant.Task.performTaszk.java:345)

T e R R R e S R R R R ST S ey

Par ailleurs, sur les terminaux SunRay il faut configurer le navigateur qui sera ouvert lorsqu’une
application Web est lancée. Pour cela sélectionnez le menu Tools>Options et dans la fenétre de
configuration qui apparait sélectionnez le navigateur Mozilla.

»
Ceneral

Web Browser: |ru1|:|2illa |v| Edit...

Options

Ve @ 8 €8

Editor Jawva Code Ruby Fontz & Colors Eeymap CfC++4+  UML  Miscellaneous

Proxy Settings: 0 Mo Proxy

i Use System Proxy Settings
i Manual Proxy Settings
HTTP Prozxy:

hore...

Advanced Options Cancel
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